RIP and EIGRP Configuration on same network

Satish Tiwary's picture

After static routing configuration, and dynamice routing configuration we are going to introduce Hybrid Routing Configuration here now. We will use RIP and EIGRP together and merge them to get the benefits of Distance vector and Link State. So when you use both RIP and EIGRP together then the most accurate metrics to determine the best path to destination automatically get changed with change in network topology.This type of routing is allowed for rapid convergence but consume less memory and lesser processing power.

This article is mainly concentrated on configuration of RIP and EIGRP together to get the above mentioned benefits.Now see the benefits of using this type of routing configuration.This type of configurational method is used when we want to inject all routes in EIGRP Autonomous system to RIP database and show up as a regular rip route, and not only this, but we can also inject routes from RIP to EIGRP topology Table using the same concept and then advertise these rip routes throughout the autonomous system as an EIGRP External Route.  

  

 
 
Configuration on Router  R1
we are going to assign ip address on both ethernet port and serial port,hostname,up port,set clock rate on serial port,assign bandwith on router R1.
 
Router>enable
Router#config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
 
R!(config)#hostname R1
R1(config)#int fa0/0
R1(config-if)#ip address 10.0.0.1 255.0.0.0
R1(config-if)#no shutdown
 
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
 
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
 
R1(config-if)#exit
 
 
R1(config)#int se0/0/0
R1(config-if)#ip address  20.0.0.1 255.0.0.0
R1(config-if)#clock rate 64000
R1(config-if)#bandwidth 64
R1(config-if)#no shutdown
 
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
R1(config-if)#exit
 
 
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#network 10.0.0.0
R1(config-router)#network 20.0.0.0
R1(config-router)#exit
 
 
 
 
Configuration on Router R2
assign ip address on both ethernet and serial port,assign bandwith,clock rate on router R2.
 
Router>enable
Router#config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R2
R2(config)#interface se0/0/0
R2(config-if)#ip address 20.0.0.2 255.0.0.0
R2(config-if)#bandwidth 64
R2(config-if)#no shutdown
 
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
 
R2(config-if)#exit
 
 
Now Configure Router RIP and EIGRP on Router R2.
 
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#exit
.
 
R2(config)#router eigrp 1
R2(config-router)#network 20.0.0.0
R2(config-router)#network 30.0.0.0
R2(config-router)#exit
R2(config)#
 
R2(config)#interface se0/0/1
R2(config-if)#ip address 30.0.0.1 255.0.0.0
R2(config-if)#bandwidth 64
R2(config-if)#clock rate 64000
R2(config-if)#no shutdown

 

 
 
Configuration on Router R3
We assigned hostname and address firts and then we up the network interface.
 
Router>enable
Router#config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R3
R3(config)#int fastEthernet 0/0
 
R3(config-if)#ip address 40.0.0.1 255.0.0.0
R3(config-if)#no shutdown
 
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
 
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
 
R3(config-if)#exit
R3(config)#int se0/0/0
R3(config-if)#ip address 30.0.0.2 255.0.0.0
 
R3(config-if)#bandwidth 64
 
R3(config-if)#clock rate 64000
R3(config-if)#no shutdown
 
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
 
R3(config-if)#router rip
R3(config-router)#version 2
R3(config-router)#network 30.0.0.0
R3(config-router)#network 40.0.0.0
R3(config-router)#exit
 
R3(config)#router eigrp 1
R3(config-router)#network 30.0.0.0
R3(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 30.0.0.1 (Serial0/0/0) is up: new adjacency
 
R3(config-router)#network 40.0.0.0
R3(config-router)#exit
 
 
 
Troubleshooting PART:
 
Troubleshooting is the major part of a network admin life or a system admin life.To find error and solve it you must be good in trobleshooting.Once you have successfully configured routing on a router you need to verify or troubleshoot whether your configured task is working properly or not.
 
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
C    10.0.0.0/8 is directly connected, FastEthernet0/0
C    20.0.0.0/8 is directly connected, Serial0/0/0
R    30.0.0.0/8 [120/1] via 20.0.0.2, 00:00:12, Serial0/0/0
R    40.0.0.0/8 [120/2] via 20.0.0.2, 00:00:12, Serial0/0/0
R1#
 
how to see neighbour Table?
 
 
R2#show ip eigrp neighbors 
IP-EIGRP neighbors for process 1
H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   30.0.0.2        Se0/0/1        13   00:30:07  40     1000  0   3
 
 
How to see the type and and number of packets sent or recieved?
 
R2#show ip eigrp traffic 
IP-EIGRP Traffic Statistics for process 1
  Hellos sent/received: 835/416
  Updates sent/received: 4/2
  Queries sent/received: 0/0
  Replies sent/received:  0/0
  Acks sent/received:  2/3
  Input queue high water mark 1, 0 drops
  SIA-Queries sent/received: 0/0
  SIA-Replies sent/received: 0/0
 
 
 
how to see the information of running proceess on interfaces?
Below command will show you detail information on interfaces taking part in eigrp process.
 
R2#show ip eigrp  interfaces 
IP-EIGRP interfaces for process 1
 
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0/1            1        0/0      1236       0/10           0           0
Se0/0/0            0        0/0      1236       0/10           0           0
 
Rate this article: 
Average: 4.4 (8 votes)

Add new comment

Plain text

  • No HTML tags allowed.
  • Web page addresses and e-mail addresses turn into links automatically.
  • Lines and paragraphs break automatically.
Type the characters you see in this picture. (verify using audio)
Type the characters you see in the picture above; if you can't read them, submit the form and a new image will be generated. Not case sensitive.